以前针对WordPress的安全方面做了些修改,首先就是隐藏WordPress的版本信息,这使有些恶意用户想针对特定版本的漏洞进行攻击就不那么容易了,相信很多WordPress用户都做过此类修改吧.
但是最近我发现网站的源码里有这么一段代码:

1
2
3
4
5
6
7
8
9
<p style="margin:0;padding:0;height:1px;">
<script type="text/javascript"><!--
        var wumiiSitePrefix = "http://imfang.net";
        var wumiiEnableCustomPos = false;
        var wumiiParams = "&num=8&mode=3&displayInFeed=1&version=1.0.5.7&pf=WordPress3.9";
        var wumiiCategories = ["\u514d\u8d39\u4e00\u7f51\u6253\u5c3d"];
//--></script>
<script type="text/javascript" src="http://widget.wumii.com/ext/relatedItemsWidget.htm?type=1&amp;num=4&amp;mode=3&amp;pf=WordPress&amp;theme=loper"></script><a href="http://www.wumii.com/widget/relatedItems" style="border:0;"><img src="http://static.wumii.cn/images/pixel.png" alt="无觅相关文章插件,快速提升流量" style="border:0;padding:0;margin:0;" /></a>
</p>

其中下面的这段代码明显的暴露了WordPress的版本号:

var wumiiParams = "&num=8&mode=3&displayInFeed=1&version=1.0.5.7&pf=WordPress3.9";

从代码分析来看,应该是后来安装的无觅相关文章插件的代码.我找到了无觅插件文件夹里的"wumii-related-posts.php"这个文件,试着修改和删除

var wumiiParams = "$queryParams";

这段代码,结果都不行,
不论是删除或修改了这段代码的值都会导至无觅插件不能正常显示.无奈只有到网上看看有没有好的解决办法,很遗憾网上竟然没有关于无觅这段代码的问题!可能大家都不在乎这个问题吧,也可能是我大惊小怪吧.
意外的发现了无觅插件代码里的一段暗链:

<a href="http://www.wumii.com/widget/relatedItems" style="border:0;"><img src="http://static.wumii.cn/images/pixel.png" alt="无觅相关文章插件,快速提升流量" style="border:0;padding:0;margin:0;" /></a>

有网友专门针对此暗链咨询了无觅客服,客服也给出了解释此暗链可以删除,我也试着删除了此暗链发现对无觅插件无任何影响,不过我的问题还是没有解决.
后来我也给无觅客服发了邮件(但至今无回音?鄙视一下),又请教了几个网友还是没有好的解决办法.最后无意中发现我的主题里就有无觅相关插件的代码预留设置,我首先停用了自己安装的无觅插件,然后启用了主题预留的无觅代码,发现纠结了很久的WordPress版本号没有了.
因为这段代码是主题作者预留好的,不知道在其他主题中能不能适用,我就不在这里放出来了,有需要代码的朋友请给我留言.

您可以用微信/QQ/支付宝扫描二维码为作者打赏
网站维护离不开您的支持
pay_weixinpay_zhifubaopay_QQ
每人打赏一块钱,助力站长把梦圆!~

声明:除非注明!方阁志文章均为原创,转载请以链接形式标明本文地址!

文章标题:无觅相关文章插件代码显示WordPress版本号问题

原文链接: http://imfang.net/wordpress/36.html